import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(xi-)?(([A-Za-z0-9]+)_?)-.*";
final String string = "xi-AN224432_-_this_is_some_text-x10.pdf\n"
+ "xi-F1800X7T2P5P-blahblah-v01_00-EN.pdf\n"
+ "1E303S-blahblah-v01_20-EN.pdf";
final String subst = "$2 or $3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}