// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(xi-)?(([A-Za-z0-9]+)_?)-.*").unwrap();
let string = "xi-AN224432_-_this_is_some_text-x10.pdf
xi-F1800X7T2P5P-blahblah-v01_00-EN.pdf
1E303S-blahblah-v01_20-EN.pdf";
let substitution = "$2 or $3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}