#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(xi-)?(([A-Za-z0-9]+)_?)-.*"
Local $sString = "xi-AN224432_-_this_is_some_text-x10.pdf" & @CRLF & _
"xi-F1800X7T2P5P-blahblah-v01_00-EN.pdf" & @CRLF & _
"1E303S-blahblah-v01_20-EN.pdf"
Local $sSubst = "$2 or $3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)