# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/>>(.*)>>(.*)>>\s//g;t' <<< "Текст >>Название ссылки>>https://example.com>> и сайт >>ссылка 2>>https://noodleremover.news/putinfakevideo-aa752ab5123>>.>>(.*)>>(.*)>>\s"