import Foundation
let pattern = #">>(.*)>>(.*)>>\s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Текст >>Название ссылки>>https://example.com>> и сайт >>ссылка 2>>https://noodleremover.news/putinfakevideo-aa752ab5123>>.>>(.*)>>(.*)>>\s"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)