use strict;
my $str = 'Текст >>Название ссылки>>https://example.com>> и сайт >>ссылка 2>>https://noodleremover.news/putinfakevideo-aa752ab5123>>.>>(.*)>>(.*)>>\\s';
my $regex = qr/>>(.*)>>(.*)>>\s/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";