$re = '/>>(.*)>>(.*)>>\s/';
$str = 'Текст >>Название ссылки>>https://example.com>> и сайт >>ссылка 2>>https://noodleremover.news/putinfakevideo-aa752ab5123>>.>>(.*)>>(.*)>>\\s';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;