import re
regex = re.compile(r">>(.*)>>(.*)>>\s")
test_str = "Текст >>Название ссылки>>https://example.com>> и сайт >>ссылка 2>>https://noodleremover.news/putinfakevideo-aa752ab5123>>.>>(.*)>>(.*)>>\\s"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)