re = />>(.*)>>(.*)>>\s/
str = 'Текст >>Название ссылки>>https://example.com>> и сайт >>ссылка 2>>https://noodleremover.news/putinfakevideo-aa752ab5123>>.>>(.*)>>(.*)>>\\s'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result