#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ">>(.*)>>(.*)>>\s"
Local $sString = "Текст >>Название ссылки>>https://example.com>> и сайт >>ссылка 2>>https://noodleremover.news/putinfakevideo-aa752ab5123>>.>>(.*)>>(.*)>>\s"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)