using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+_(.+\-\d+\-\d+\-.+)";
string input = @"LB_AB_BookingReminder_123-1-2-1S
LB_AB_123-1-2-1S
LB_AB_Booking_Reminder_123-1-2-1S";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}