// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.+_(.+\-\d+\-\d+\-.+)").unwrap();
let string = "LB_AB_BookingReminder_123-1-2-1S
LB_AB_123-1-2-1S
LB_AB_Booking_Reminder_123-1-2-1S";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}