re = /^.+_(.+\-\d+\-\d+\-.+)/m
str = 'LB_AB_BookingReminder_123-1-2-1S
LB_AB_123-1-2-1S
LB_AB_Booking_Reminder_123-1-2-1S'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end