const regex = new RegExp('^.+_(.+\\-\\d+\\-\\d+\\-.+)', 'gm')
const str = `LB_AB_BookingReminder_123-1-2-1S
LB_AB_123-1-2-1S
LB_AB_Booking_Reminder_123-1-2-1S`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}