package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.+_(.+\-\d+\-\d+\-.+)`)
var str = `LB_AB_BookingReminder_123-1-2-1S
LB_AB_123-1-2-1S
LB_AB_Booking_Reminder_123-1-2-1S`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}