import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+_(.+\\-\\d+\\-\\d+\\-.+)";
final String string = "LB_AB_BookingReminder_123-1-2-1S\n"
+ "LB_AB_123-1-2-1S\n"
+ "LB_AB_Booking_Reminder_123-1-2-1S";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}