#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s):\s?(a90[\d]+|[$][\d]+|[A-Z]{3}|.*$)"
Local $sString = "ID: a9000006 " & @CRLF & _
"NSF Org : DMI" & @CRLF & _
"Total Amt. : $225024" & @CRLF & _
"" & @CRLF & _
"Abstract :This SBIR proposal is aimed at (1) the synthesis of new ferroelectric liquid crystals with ultra-high polarization, " & @CRLF & _
" chemical stability and low viscosity"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")