re = /:\s?(a90[\d]+|[$][\d]+|[A-Z]{3}|.*$)/
str = 'ID: a9000006
NSF Org : DMI
Total Amt. : $225024
Abstract :This SBIR proposal is aimed at (1) the synthesis of new ferroelectric liquid crystals with ultra-high polarization,
chemical stability and low viscosity'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end