package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s):\s?(a90[\d]+|[$][\d]+|[A-Z]{3}|.*$)`)
var str = `ID: a9000006
NSF Org : DMI
Total Amt. : $225024
Abstract :This SBIR proposal is aimed at (1) the synthesis of new ferroelectric liquid crystals with ultra-high polarization,
chemical stability and low viscosity`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}