import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":\\s?(a90[\\d]+|[$][\\d]+|[A-Z]{3}|.*$)";
final String string = "ID: a9000006 \n"
+ "NSF Org : DMI\n"
+ "Total Amt. : $225024\n\n"
+ "Abstract :This SBIR proposal is aimed at (1) the synthesis of new ferroelectric liquid crystals with ultra-high polarization, \n"
+ " chemical stability and low viscosity";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}