const regex = /:\s?(a90[\d]+|[$][\d]+|[A-Z]{3}|.*$)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':\\s?(a90[\\d]+|[$][\\d]+|[A-Z]{3}|.*$)', 'gs')
const str = `ID: a9000006
NSF Org : DMI
Total Amt. : \$225024
Abstract :This SBIR proposal is aimed at (1) the synthesis of new ferroelectric liquid crystals with ultra-high polarization,
chemical stability and low viscosity`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}