import re
regex = re.compile(r":\s?(a90[\d]+|[$][\d]+|[A-Z]{3}|.*$)", flags=re.DOTALL)
test_str = ("ID: a9000006 \n"
"NSF Org : DMI\n"
"Total Amt. : $225024\n\n"
"Abstract :This SBIR proposal is aimed at (1) the synthesis of new ferroelectric liquid crystals with ultra-high polarization, \n"
" chemical stability and low viscosity")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")