# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*[a-zA-Z.].*(*SKIP)(*FAIL)|\B(?=(\d{3})+(?!\d))/,/gm;t' <<< "Good
1
23
123
1234
12345
752892
1234567
Bad
123123456.000000
12a3123456.0000000000
123456.12345a12345"