$re = '/.*[a-zA-Z.].*(*SKIP)(*FAIL)|\B(?=(\d{3})+(?!\d))/m';
$str = 'Good
1
23
123
1234
12345
752892
1234567
Bad
123123456.000000
12a3123456.0000000000
123456.12345a12345';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;