import Foundation
let pattern = #".*[a-zA-Z.].*(*SKIP)(*FAIL)|\B(?=(\d{3})+(?!\d))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Good
1
23
123
1234
12345
752892
1234567
Bad
123123456.000000
12a3123456.0000000000
123456.12345a12345
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)