using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*[a-zA-Z.].*(*SKIP)(*FAIL)|\B(?=(\d{3})+(?!\d))";
string substitution = @",";
string input = @"Good
1
23
123
1234
12345
752892
1234567
Bad
123123456.000000
12a3123456.0000000000
123456.12345a12345";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}