import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*[a-zA-Z.].*(*SKIP)(*FAIL)|\\B(?=(\\d{3})+(?!\\d))";
final String string = "Good\n"
+ "1\n"
+ "23\n"
+ "123\n"
+ "1234\n"
+ "12345\n"
+ "752892\n"
+ "1234567\n"
+ "Bad\n"
+ "123123456.000000\n"
+ "12a3123456.0000000000\n"
+ "123456.12345a12345";
final String subst = ",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}