#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*[a-zA-Z.].*(*SKIP)(*FAIL)|\B(?=(\d{3})+(?!\d))"
Local $sString = "Good" & @CRLF & _
"1" & @CRLF & _
"23" & @CRLF & _
"123" & @CRLF & _
"1234" & @CRLF & _
"12345" & @CRLF & _
"752892" & @CRLF & _
"1234567" & @CRLF & _
"Bad" & @CRLF & _
"123123456.000000" & @CRLF & _
"12a3123456.0000000000" & @CRLF & _
"123456.12345a12345"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)