# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\\\|\\\*|\*\*((?:\\\\|\\\*\*|\*(?!\*)|[\S\s])*?)\*\*/$0\t\t\t<strong>$1<strong>/g;t' <<< "**bold**
**foo * bar **
**foo \** bar**
**foo \\** bar** **
\**bold** **
\\**bold**
"