use strict;
my $str = '**bold**
**foo * bar **
**foo \\** bar**
**foo \\\\** bar** **
\\**bold** **
\\\\**bold**
';
my $regex = qr/\\\\|\\\*|\*\*((?:\\\\|\\\*\*|\*(?!\*)|[\S\s])*?)\*\*/p;
my $subst = '$0\\t\\t\\t<strong>$1<strong>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";