using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\\\|\\\*|\*\*((?:\\\\|\\\*\*|\*(?!\*)|[\S\s])*?)\*\*";
string substitution = @"$0\t\t\t<strong>$1<strong>";
string input = @"**bold**
**foo * bar **
**foo \** bar**
**foo \\** bar** **
\**bold** **
\\**bold**
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}