$re = '/\\\\\\\\|\\\\\*|\*\*((?:\\\\\\\\|\\\\\*\*|\*(?!\*)|[\S\s])*?)\*\*/';
$str = '**bold**
**foo * bar **
**foo \\** bar**
**foo \\\\** bar** **
\\**bold** **
\\\\**bold**
';
$subst = "$0\t\t\t<strong>$1<strong>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;