re = /\\\\|\\\*|\*\*((?:\\\\|\\\*\*|\*(?!\*)|[\S\s])*?)\*\*/
str = '**bold**
**foo * bar **
**foo \\** bar**
**foo \\\\** bar** **
\\**bold** **
\\\\**bold**
'
subst = '$0\\t\\t\\t<strong>$1<strong>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result