#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\\\\|\\\*|\*\*((?:\\\\|\\\*\*|\*(?!\*)|[\S\s])*?)\*\*"
Local $sString = "**bold**" & @CRLF & _
"**foo * bar **" & @CRLF & _
"**foo \** bar**" & @CRLF & _
"**foo \\** bar** **" & @CRLF & _
"\**bold** **" & @CRLF & _
"\\**bold**" & @CRLF & _
""
Local $sSubst = "$0\t\t\t<strong>$1<strong>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)