# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\{\{Term\|([^|]+)\|content=([a-z]+)}}}/{{Term|$2}}/gm;t' <<< "{{Term|AbCdEf|content=abcdef}}
{{Term|AbCdEf|content=abcdef}}
{{Term|ABC|content=abc}}
Term|AbCdEf|content=abcdef
{{Term|AbCdEf|content=abcde}}
{{Term|AbCdE|content=abcdef}}
{{Term|AbCdEf|content=aBcdef}}
{{Term|content=}}"