// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\{\{Term\|([^|]+)\|content=([a-z]+)}}}").unwrap();
let string = "{{Term|AbCdEf|content=abcdef}}
{{Term|AbCdEf|content=abcdef}}
{{Term|ABC|content=abc}}
Term|AbCdEf|content=abcdef
{{Term|AbCdEf|content=abcde}}
{{Term|AbCdE|content=abcdef}}
{{Term|AbCdEf|content=aBcdef}}
{{Term|content=}}";
let substitution = "{{Term|$2}}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}