$re = '/^\{\{Term\|([^|]+)\|content=([a-z]+)}}}/m';
$str = '{{Term|AbCdEf|content=abcdef}}
{{Term|AbCdEf|content=abcdef}}
{{Term|ABC|content=abc}}
Term|AbCdEf|content=abcdef
{{Term|AbCdEf|content=abcde}}
{{Term|AbCdE|content=abcdef}}
{{Term|AbCdEf|content=aBcdef}}
{{Term|content=}}';
$subst = "{{Term|$2}}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;