use strict;
my $str = '{{Term|AbCdEf|content=abcdef}}
{{Term|AbCdEf|content=abcdef}}
{{Term|ABC|content=abc}}
Term|AbCdEf|content=abcdef
{{Term|AbCdEf|content=abcde}}
{{Term|AbCdE|content=abcdef}}
{{Term|AbCdEf|content=aBcdef}}
{{Term|content=}}';
my $regex = qr/^\{\{Term\|([^|]+)\|content=([a-z]+)}}}/mp;
my $subst = '{{Term|$2}}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";