const regex = /^\{\{Term\|([^|]+)\|content=([a-z]+)}}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\{\\{Term\\|([^|]+)\\|content=([a-z]+)}}}', 'gm')
const str = `{{Term|AbCdEf|content=abcdef}}
{{Term|AbCdEf|content=abcdef}}
{{Term|ABC|content=abc}}
Term|AbCdEf|content=abcdef
{{Term|AbCdEf|content=abcde}}
{{Term|AbCdE|content=abcdef}}
{{Term|AbCdEf|content=aBcdef}}
{{Term|content=}}`;
const subst = `{{Term|$2}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);