use strict;
my $str = '/cab/user/core1/bdc49fd8/bd77de6ce';
my $regex = qr/(?:/[a-fA-Z0-9]*)+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";