// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:/[a-fA-Z0-9]*)+$").unwrap();
let string = "/cab/user/core1/bdc49fd8/bd77de6ce";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}