using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cursos\/(.+)\/(.+)";
string substitution = @"";
string input = @"meusite.com/cursos/matem/algebra-linear
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}