import re
regex = re.compile(r"cursos\/(.+)\/(.+)")
test_str = ("meusite.com/cursos/matem/algebra-linear\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)