const regex = /cursos\/(.+)\/(.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('cursos\\\/(.+)\\\/(.+)', 'g')
const str = `meusite.com/cursos/matem/algebra-linear
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);