import Foundation
let pattern = #"cursos\/(.+)\/(.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
meusite.com/cursos/matem/algebra-linear
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)