$re = '/cursos\/(.+)\/(.+)/';
$str = 'meusite.com/cursos/matem/algebra-linear
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;