# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/&([aeoz])uml\b/ $1/gm;t' <<< "ä
&zuml
ö
ë
"