const regex = new RegExp('&([aeoz])uml\\b', 'gm')
const str = `ä
&zuml
ö
ë
`;
const subst = ` $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);