$re = '/&([aeoz])uml\b/m';
$str = 'ä
&zuml
ö
ë
';
$subst = " $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;