using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&([aeoz])uml\b";
string substitution = @" $1";
string input = @"ä
&zuml
ö
ë
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}